Version 8.5 > installed fonts not showing on screen


5/22/2019 2:52:29 PM
I recently had a serious Win 10 crash and they were able to only reinstall
Win 10. I have been slowly reinstalling all my programs (a list 4 pages
long). SSP has been reinstalled and seems to work OK. I had some fonts
that I used regularly that were not part of the windows installation, so
I have installed them -- two of them are "biblescript" and "virtue." When
I edit text in a slide show these installed fonts show correctly in the
edit box, but when I exit from that box, the font displayed is Ariel
(I believe). When I display the slide show in the embedded monitors
it is also Ariel. The same situation applies for songs, I can add text
as Biblescript, for example, in the editor, but it displays as Ariel.
GFM took control of my PC but they weren't able to find a solution.
Any suggestions would be appreciated.

5/23/2019 9:45:11 AM
Hi Dick. sorry to hear about your font problem.  We do have some KB articles that address this but before I get to that, I am curious about a couple of things...

You said you are having problems after a crash, so are you saying that these fonts worked before the crash?

The fonts you mentioned - what is the source and type?

You stated that GFM took control and did not find a solution - what was done after that?

Regarding the KBs - Please review these two - they should shed some light on the proper next steps.


5/24/2019 9:06:24 AM
Everything worked fine before the crash (initiated by Windows 10 update!). The IT's
had to reinstalled Windows and I lost most of the programs, but no data. I reinstalled
SSP 8.5 without issues. Soon I noticed that Biblescript and Virtue ttf fonts were not installed,
so I installed them from existing files. That's when I noticed that those fonts looks OK
in the editor pane, but showed up as Ariel (I think) otherwise; i.e. in the Builder
screen and in the embedded screens of SSP.

After reading the KB articles, I checked the fonts and found that in the Windows\Fonts
folder the new installed fonts are shortcuts to users\...\appdata\local\microsoft\windows\fonts.
I have found no way to installed them "normally" in the fonts directory -- every time I try
to install, it creates the shortcut.

When I take the files to church, they project correctly, PTL.

I going to see if I can find another font installer that will work correctly.

By the way, I did see that "display text as entered" was selected (but for the life
of me, I can't find that screen again!)


5/27/2019 9:31:46 AM
After searching and asking all around without success, I finally stumbled on a solution.
In control panel/fonts/font settings, the box for "Allow fonts to be installed as a shortcut (advanced)"
was unchecked -- of course one would assume that meant NO shortcuts, but apparently not!
So I checked it. Now, if I right-ciick on a font to install, I get two options:
"Install for all users" and "Install as a shortcut for all users." The first of these will
install the fonts in the windows\fonts folder as a font file and SSB will show it correctly.

It is hard to see why MS is so obscure -- and why SSP can't use a font shortcut :-(

By the way, I did see that "display text as entered" was selected (but for the life
of me, I can't find that screen again!)

5/28/2019 12:11:22 PM

Yeah the Windows font thing is a little odd.  Not sure what the deal is with the shortcuts but I know that has been an issue for some time.

I am still not clear though on what checkbox or entry you are looking for in SSB - did I miss something?  Not sure what you are referring to - please elaborate. 

5/28/2019 5:53:55 PM
Somewhere in SSB there is a check box titled something like
"show text as entered" and I think the other option is
"show text as default."
Maybe I was imagining it -- hey, I'm 84 and get to do that
now and then! ;-)

6/3/2019 9:32:07 AM
Hey again Dick.

That control did not ring any bells but I took a look thorough SSB and did not find anything.  There are similarly named controls in SSP - is that what you were thinking?  In any case, regardless of the name, it there a particular control or function/setting you were look for?  Maybe it is called something else.  What were you trying to do?

6/5/2019 8:10:29 AM
I traced back where I saw the statement in question:

Select a text box
Click Object Tools
Main text
Font Properties
Text Properties
select "use default name" or "use the fonts contained in the text contents"

This probably has nothing to do with the problem, but it caught my eye as I was
trying to figure out what was wrong.

One of the characteristics of SSP is that it is very versatile, but at the expense of
complexity, i.e. many (maybe too many!) ways to set properties.

Thanks for looking into this for me, George.

7/5/2019 2:35:10 PM
I still wish you'd allow OTF fonts. I can't always convert to TTF.

Windows allows them. Not sure why you don't.

To post messages to the forums you must be signed in to a user account.
An error has occurred. This application may no longer respond until reloaded. Reload 🗙